Dhcp сервер на cisco

Рейтинг статьи: 0.000/5 (0 голосов).

Настраивая оборудование в крупных органицациях, где есть требование высокой отказоустойчивости, начинаешь планировать отказоустойчивый DHCP сервер. Настраиваем DHCP сервера на 2 маршрутизаторах Cisco.

Спонсор этой страницы:

Разделение адресного пространства

При организации двух DHCP серверов разные IT монстры предлагают делить по разному.

В общем перинято делить IP пространство 50% на 50% или 80% на 20%.

Мне больше нравится 50% на 50%.

Примерное задание.

Имеем сеть 192.168.1.0/24

в этой сети 2 маршрутизатора: 192.168.1.253 и 192.168.1.254, объединеные по HSRP или GLBP.

Шлюз по умолчанию для пользователей 192.168.1.1

DNS сервера 192.168.1.251, 192.168.1.252

WINS сервера 192.168.1.251, 192.168.1.252

DHCP pool для пользоватей 192.168.1.100-192.168.1.199

Разделяем адресное пространство DHCP в пропорции 50% на 50%.

Router 1 — 192.168.1.100-192.168.1.149
Router 2 — 192.168.1.150-192.168.1.199

Настройка DHCP pool на маршрутизаторе

router1

Первое: исключаем невыдаваемые адреса

ip dhcp excluded-address 192.168.1.0 192.168.1.99
ip dhcp excluded-address 192.168.1.150 192.168.1.255

Организовавем DHCP pool

ip dhcp pool central
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
netbios-name-server 192.168.1.251 192.168.1.252
netbios-node-type h-node
dns-server 192.168.1.251 192.168.1.252
option 4 ip 192.168.1.1
option 150 ip 192.168.1.2
lease 7

network — описание сети

default-router — шлюз по умолчанию

netbios-name-server указывает, какие будут использоваться wins сервера.
Если вы Wins не используете, можете в конфиге эту строчку опустить.

Вообще для запуска DHCP сервера достаточно создать pool и указать сеть командой network. Все остальное это опции.

netbios-node-type — тип узла для NETBIOS сервера. В примере гибридный.

dns-server передает список DNS серверов.

lease 7 — срок на который выдается IP адрес. в данной настройке 7 дней.

option 4 указывает NTP сервер.

option 150 указывает адрес TFTP сервера для IP телефонии.

router2

Все тоже самое, за исключением

ip dhcp excluded-address 192.168.1.0 192.168.1.149
ip dhcp excluded-address 192.168.1.200 192.168.1.255

Привязка DHCP pool к MAC адресу станции.

Иногда необходимо конкретной машине выдать конкретный IP адрес.

Ждем, когда данная машина получит IP адрес.

Смотрим на маршрутизаторе.

sh arp | i 192.168.1.123
Internet 192.168.1.123 0 0050.53a7.1234 ARPA FastEthernet0/0.1

sh ip dhcp binding | i 192.168.1.123
192.168.1.123 0100.5053.a712.34 Oct 26 2012 01:56 PM Automatic

Мы видим, что запись в ARP таблице и в DHCP разные.

Добавляем на обоих маршрутизаторах описание станции, так, как она записана в таблице DHCP.

ip dhcp pool sql-server
host 192.168.1.33 255.255.255.0
client-identifier 0100.5053.a712.34

Как это работает

Шаг первый

Вначале клиент выполняет широковещательный запрос по всей физической сети с целью обнаружить доступные DHCP-серверы. Он отправляет сообщение типа DHCPDISCOVER, при этом в качестве IP-адреса источника указывается 0.0.0.0 (так как компьютер ещё не имеет собственного IP-адреса), а в качестве адреса назначения — широковещательный адрес 255.255.255.255.

Данный запрос получают оба DHCP сервера

Шаг второй

Оба сервера отправляет ему ответ (DHCPOFFER), в котором предлагает свои конфигурации. Предлагаемый клиенту IP-адрес указывается в поле yiaddr. Оба сервера отправлеют данную информацию напрямую клиенту.

Шаг третий

Выбрав одну из конфигураций, предложенных DHCP-серверами (скорее всего ту, которая прилетела первой), клиент отправляет запрос DHCP (DHCPREQUEST). Он рассылается широковещательно; при этом к опциям, указанным клиентом в сообщении DHCPDISCOVER, добавляется специальная опция — идентификатор сервера — указывающая адрес DHCP-сервера, выбранного клиентом

Шаг четвертый

Выбранный клиентом сервер подтверждает запрос и направляет это подтверждение (DHCPACK) клиенту. После этого клиент настраивает свой сетевой интерфейс, используя предоставленные опции.

На этом все. Распределения нагузки и высокой отказоустойчивости.

Комментарии к статье:

Cisco сделала DHCP Server на бюджетном L2/L3 коммутаторе SB — SF300. Неделю как работает. ну а на роутерах вроде проблем вообще не было никогда

Ваши отзывы и предложения по работе сайта направляйте на форму обратной связи.

Полезно

Узнать IP — адрес компьютера в интернете

Онлайн генератор устойчивых паролей

Онлайн калькулятор подсетей

Калькулятор инсталляции IP — АТС Asterisk

Руководство администратора FreePBX на русском языке

Руководство администратора Cisco UCM/CME на русском языке

Навигация

Серверные решения

Телефония

FreePBX и Asterisk

Настройка программных телефонов

Корпоративные сети

Популярное и похожее

Настройка Site-To-Site IPSec VPN на Cisco

Настройка Router-on-a-Stick на Cisco

Настройка EtherChannel на Cisco

Cisco ASA: блокировка доступа к сайтам

Настройка DHCP на оборудовании Cisco

3 минуты чтения

Друг, наша предыдущая статья была посвящена рассказу о том, что из себя представляет протокол DHCP (Dynamic Host Configuration Protocol). Сегодня мы расскажем, как его настроить на оборудовании Cisco.

Маршрутизатор Cisco, работающий под управлением программного обеспечения Cisco IOS, может быть настроен на работу в качестве DHCP сервера. Сервер назначает и управляет адресами IPv4 из указанных пулов адресов в маршрутизаторе для DHCP клиентов.

Исключение адресов IPv4

Маршрутизатор, работающий как DHCP сервер, назначает все адреса IPv4 в диапазоне (пуле), если не настроен на исключение определенных адресов. Как правило, некоторые IP адреса из пула принадлежат сетевым устройствам, таким как маршрутизаторы, сервера или принтеры, которым требуются статические адреса, поэтому эти адреса не должны назначаться другим устройствам. Чтобы их исключить, используется команда ip dhcp excluded-address. При помощи этой команды можно исключить как один единственный адрес, так и диапазон адресов, указав из него первый и последний.

Рассмотрим на примере, в котором исключим из раздачи адрес 192.168.1.254 и адреса с 192.168.1.1 по 192.168.1.9

Настройка DHCP пула

Настройка DHCP сервера включает в себя определение пула адресов, которые будут раздаваться. Для создания пула используется команда ip dhcp pool [название_пула]. После этого необходимо ввести две обязательные команды – network [адрес_сети][маска/длина_префикса] для указания сети из которой будут раздаваться адреса и default-router[адрес_default_gateway] для указания шлюза по умолчанию (можно ввести до 8 адресов).

Также можно использовать дополнительные команды – например, указать DNS сервер (команда dns-server [адрес]), доменное имя (команда domain-name [домен]), NetBIOS WINS сервер (команда netbios-name-server[адрес]), а так же время аренды адреса (команда lease [количество_дней_часов_минут], сначала указываются дни, затем через пробел часы, а затем минуты). По умолчанию время аренды выставляется 1 день.

Чтобы выполнить проверку можно использовать команду show ip dhcp binding, которая показывает список всех IP адресов и сопоставленных с ними MAC адресов, которые были выданы DHCP сервером. Также есть команда show ip dhcp server statistics, используя которую можно увидеть статистику DHCP сервера, включая информацию об отправленных и полученных DHCP сообщениях. Ну и если клиентом является ПК с ОС Windows, то информацию можно посмотреть через командную строку, введя команду ipconfig /all, а для пользователей Linux подойдет команда ifconfig.

Ретрансляция DHCP (DHCP Relay)

В сложной иерархической сети серверы обычно находятся не в той же сети, что и клиенты. В результате если DHCP сервер находится в другой сети, то до него не смогут доходить запросы от клиентов, поскольку маршрутизаторы не пересылают широковещательные сообщения. Чтобы решить эту проблему нужно воспользоваться командной ip helper-address [адрес_DHCP-сервера], которую нужно ввести на маршрутизаторе в режиме конфигурации интерфейса, чтобы он перенаправлял broadcast сообщения от DHCP клиентов уже в виде unicast к DHCP серверу, находящемуся в другой сети.

Настройка роутера как DHCP клиента

Иногда роутер сам должен получить IP адрес по DHCP, например от интернет-провайдера. Для этого нужно в режиме конфигурации интерфейса ввести команду ip address dhcp, после чего интерфейс будет пытаться получить адрес от DHCP сервера.

Пожалуйста, расскажите почему?

Нам жаль, что статья не была полезна для вас 🙁 Пожалуйста, если не затруднит, укажите по какой причине? Мы будем очень благодарны за подробный ответ. Спасибо, что помогаете нам стать лучше!

Подпишитесь на нашу еженедельную рассылку, и мы будем присылать самые интересные публикации 🙂 Просто оставьте свои данные в форме ниже.

Протокол DHCP позволяет производить автоматическую настройку сетевых устройств. Настройка DHCP сервера на маршрутизаторе выгодна тем, что позволяет по максимум задействовать работающий маршрутизатор, повесив на него максимальное количество функционала (интернет, NAT, DHCP и т.п.). DCHP позволит маршрутизатору автоматически настраивать на клиентах следующие основные параметры:

  • IP адрес
  • Основной шлюз
  • Маска подсети
  • DNS сервера
  • Имя домена

Ниже мы приводим для вас сразу несколько разных инструкций по настройке DHCP на оборудовании Cisco.

СОДЕРЖАНИЕ:

  • Видеоурок по работе с Cisco Packet Tracer. Курс молодого бойца по настройке DHCP
  • Настройка централизованного DHCP сервера с помощью Cisco Packet Tracer
  • Листинг команд настройки маршрутизатора R1, на котором «поднят» DHCP сервер
  • Настройка DHCP сервера на маршрутизаторе Cisco, возможные причины неработоспособности сети
  • Полезные команды настройке DHCP Cisco

Видеоурок по работе с Cisco Packet Tracer. Курс молодого бойца по настройке DHCP

Настройка централизованного DHCP сервера с помощью Cisco Packet Tracer

В этой видео инструкции рассматривается процесс настройки централизованного DHCP сервера в программе Cisco Packet Tracer.

  • как настроить пулы динамических IP адресов для различных сегментов локальной сети,
  • как настроить рабочую станцию на получение динамического IP адреса,
  • как проверить наличие получения динамического IP адреса рабочей станцией.

Новые команды для настройки маршрутизатора для получения пула динамических IP адресов у централизованного DHCP сервера.

Для примера рассматривается роутер R1

Настройки производятся в режиме глобальной конфигурации:

R1(config)#interface fastEthernet 0/1 — заходим в настройки интерфейса к которому подключен компьютер получающий динамический IP адрес

R1(config-if)#ip helper-address 192.168.30.11 указывается IP адрес централизованного DHCP сервера.

Листинг команд настройки маршрутизатора R1, на котором «поднят» DHCP сервер, следующий:

R1(config)#interface Ethernet 0/1/0

R1(config-if)#ip address 172.33.56.1 255.255.255.0

R1(config)#ip dhcp excluded-address 172.33.56.1

R1(config)#ip dhcp excluded-address 172.33.56.254

R1(config)#ip dhcp pool R1SW6

R1(dhcp-config)#network 172.33.56.0 255.255.255.0

R1(config)#do sh ip prot

Routing Protocol is «bgp 1»

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

R1(config)#router bgp 1

R1(config-router)#do sh ip route

172.33.0.0/24 is subnetted, 1 subnets

C 172.33.56.0 is directly connected, Ethernet0/1/0

R1(config-router)#network 172.33.56.0 mask 255.255.255.0

Настройка DHCP сервера на маршрутизаторе Cisco, возможные причины неработоспособности сети

Рассматривается настройка DHCP сервера на маршрутизаторе Cisco, показаны возможные причины неработоспособности сети, связанные с работой протоколов маршрутизации и варианты устранения данных неполадок.

Полезные команды настройке DHCP Cisco

  • Исключим из раздачи адрес 192.168.1.254 и адреса с 192.168.1.1 по 192.168.1.9

Router(config)# ip dhcp excluded-address 192.168.1.254

Router(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.9

Настройка DHCP сервера включает в себя определение пула адресов, которые будут раздаваться. Для создания пула используется команда ip dhcp pool [название_пула]. После этого необходимо ввести две обязательные команды – network [адрес_сети][маска/длина_префикса] для указания сети из которой будут раздаваться адреса и default-router[адрес_default_gateway] для указания шлюза по умолчанию (можно ввести до 8 адресов).

  • команда show ip dhcp binding показывает список всех IP адресов и сопоставленных с ними MAC адресов, которые были выданы DHCP сервером.
  • команда show ip dhcp server statistics покажет статистику DHCP сервера, включая информацию об отправленных и полученных DHCP сообщениях
  • Ретрансляция DHCP (DHCP RELAY)

Команда ip helper-address [адрес_DHCP-сервера] на маршрутизаторе в режиме конфигурации интерфейса укажет ему перенаправлять broadcast сообщения от DHCP клиентов уже в виде unicast к DHCP серверу, находящемуся в другой сети.

  • Настройка роутера DHCP клиента

Иногда роутер сам должен получить IP адрес по DHCP, например от интернет-провайдера. Для этого нужно в режиме конфигурации интерфейса ввести команду ip address dhcp, после чего интерфейс будет пытаться получить адрес от DHCP сервера.

Цены на сайте указаны с НДС.

При безналичном расчете цена не меняется.

Доставка по России, в Казахстан, в Беларусь. По Москве БЕСПЛАТНО!

Оперативный подбор оборудования и аналогов.

«>


[an error occurred while processing the directive]
Карта сайта