Данные были изменены или удалены другим пользователем

Ошибка может возникать в нескольких случаях:

Необходимо закрыть лишние запущенные сессии.

  • Серверная версия, в которой работает несколько пользователей

Данная база запущена у другого пользователя. Для решения проблемы остальным пользователям необходимо завершить работу с базой.

Большинство хороших программистов делают свою работу не потому, что ожидают оплаты или признания, а потому что получают удовольствие от программирования (Linus Torvalds).

Страницы

вторник, 21 января 2014 г.

Данные были изменены или удалены другим пользователем (тонкий клиент)

Если при попытке записать элемент справочника или документ появляется ошибка "Данные были изменены или удалены другим пользователем", то это значит, что данные, которые отображаются на форме и данные, которые записаны в базе отличаются.

Возможно, их изменил другой пользователь или мы программно их изменили, но форму не обновили. Решить эту проблему можно, используя метод управляемой формы Прочитать(). Этот метод обновляет объект управляемой формы.

&НаКлиенте
Процедура ОбработкаОповещения ( ИмяСобытия , Параметр , Источник )

Если ИмяСобытия = "УправлениеКартамиYandex_ВыбраныКоординаты" Тогда
Если Не ЗначениеЗаполнено ( Объект . Ссылка ) Тогда
Возврат;
КонецЕсли;
ЭтаФорма . Прочитать ();
ЗаполнитьКоординаты ( Параметр );
ЭтаФорма . Прочитать ();
КонецЕсли;

Процедура ЗаполнитьКоординаты ( Параметр )

МассивСтрок = РаботаСоСтроками . РазложитьСтрокуВМассив ( Параметр , ";" );
Если МассивСтрок . Количество ()> 0 Тогда
текОбъект = Объект . Ссылка . ПолучитьОбъект ();
текОбъект . Долгота = СокрЛП ( МассивСтрок [ 0 ]);
текОбъект . Широта = СокрЛП ( МассивСтрок [ 1 ]);
текОбъект . Записать ();
КонецЕсли;

В примере, через обработку оповещения передаем параметр в процедуру, в которой присваиваем полученные координаты долготы и широты и записываем объект. Потом, используя метод Прочитать(), обновляем объект формы. В данном случае метод вызван 2 раза в связи с тем, что до заполнения координат, он изменяется, а второй раз — чтобы прочитать изменения, которые сделали мы.

13.11.2019
Как в отчете Расчет страховых взносов проставить нулевые начисления?
Ответ: На печать не выводятся данные по нулевым начислениям.
> Читать подробный ответ

13.11.2019
Если сотрудник болеет, но больничный лист не закрыт, что указать в графе?
Ответ: Нужно указать в графе "отсутствия по болезни, б/л не закрыт".

> Читать подробный ответ

13.11.2019
Не верно в справке 2-НДФЛ формируются даты начисления и выплаты дивидендов.
Ответ: В данной ситуации нужно сделать следующее:
> Читать подробный ответ

Данные были изменены или удалены другим пользователем

Ошибка может возникать в нескольких случаях: А) Запущено несколько сессий 1С — Необходимо закрыть лишние запущенные сессии. Б) Серверная версия, в которой работает несколько пользователей — Данная база запущена у другого пользователя. Для решения проблемы остальным пользователям необходимо завершить работу с базой. В) Сбой в программе — В этом случае просто перезапустите 1С

Остались вопросы? Получите бесплатную консультацию наших специалистов!

Ваш заказ успешно отправлен,

наши менеджеры свяжутся

с Вами в ближайшее время

22.02.2019
23 февраля День Защитника Отечества!
Коллектив ГК «Сервистренд» от всей души поздравляет Вас с днем защитника Отечества!
Подробнее

05.11.2019 22:50:00
Управление торговлей, редакция 11
11.4.10.75

05.11.2019 22:50:00
Управление торговлей базовая, редакция 11
11.4.10.75

07.11.2019 22:47:00
Управление нашей фирмой, редакция 1.6
1.6.19.137

08.11.2019 22:46:00
Управление нашей фирмой базовая, редакция 1.6
1.6.19.137

05.11.2019 22:46:00
Комплексная автоматизация, редакция 2
2.4.10.75

IncludeComponent( "acro:add.iblock", "its", array( "COMPONENT_TEMPLATE" => "its", "IBLOCK_TYPE" => "konsulk", "IBLOCK_ID" => "108", "ID_BUTT" => "sendOrder", "SEND_AJAX" => "Y", "LINK_SHOW" => "Y", "LINK_NAME" => "Заказать звонок", "ADD_ACTIVE" => "Y", "USE_CAPTCHA" => "N", "SUCCES_SHOW" => "Y", "SUCCES_TEXT" => "

Ваш заказ успешно отправлен,
наши менеджеры свяжутся
с вами в ближайшее время


[an error occurred while processing the directive]
Карта сайта